C4DT Informational Site

Features

Some features and descriptions of them:

Update Site

This site is also an update site to add to Eclipse. Add the URL of this site to Eclipse's list of update sites to install C4DT from here.

Requirements

As of version 2.0 Java 8 and probably Eclipse 4.4 Luna is required.

Source